Unable to start PBS service under CentOS 7.2


#1

I was unable to run PBS server on my CentOS 7.2 machine.

systemctl start pbs && systemctl status pbs shows it successfully started.

● pbs.service - Portable Batch System
Loaded: loaded (/opt/pbs/libexec/pbs_init.d; enabled; vendor preset: disabled)
Active: active (running) since Mon 2017-02-20 02:46:34 EST; 2s ago
Docs: man:pbs(8)
Process: 13091 ExecStop=/opt/pbs/libexec/pbs_init.d stop (code=exited, status=0/SUCCESS)
Process: 13581 ExecStart=/opt/pbs/libexec/pbs_init.d start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/pbs.service
└─13990 /opt/pbs/sbin/pbs_server.bin

Feb 20 02:46:34 localhost.localdomain pbs_init.d[13581]: Connecting to PBS dataservice…connected to PBS dataservice@localhost
Feb 20 02:46:34 localhost.localdomain pbs_init.d[13581]: Licenses valid for 1000000 Floating hosts
Feb 20 02:46:34 localhost.localdomain pbs_init.d[13581]: PBS server
Feb 20 02:46:34 localhost.localdomain systemd[1]: Started Portable Batch System.
Feb 20 02:46:34 localhost.localdomain su[14023]: (to postgres) root on none
Feb 20 02:46:35 localhost.localdomain su[14075]: (to postgres) root on none
Feb 20 02:46:35 localhost.localdomain su[14148]: (to postgres) root on none
Feb 20 02:46:35 localhost.localdomain su[14200]: (to postgres) root on none
Feb 20 02:46:35 localhost.localdomain su[14251]: (to postgres) root on none
Feb 20 02:46:37 localhost.localdomain su[14298]: (to postgres) root on none

However, within just 5 secs, the service was automatically shut down, systemctl status pbs:

● pbs.service - Portable Batch System
Loaded: loaded (/opt/pbs/libexec/pbs_init.d; enabled; vendor preset: disabled)
Active: inactive (dead) since Mon 2017-02-20 02:46:41 EST; 1min 24s ago
Docs: man:pbs(8)
Process: 14479 ExecStop=/opt/pbs/libexec/pbs_init.d stop (code=exited, status=0/SUCCESS)
Process: 13581 ExecStart=/opt/pbs/libexec/pbs_init.d start (code=exited, status=0/SUCCESS)

Feb 20 02:46:35 localhost.localdomain su[14148]: (to postgres) root on none
Feb 20 02:46:35 localhost.localdomain su[14200]: (to postgres) root on none
Feb 20 02:46:35 localhost.localdomain su[14251]: (to postgres) root on none
Feb 20 02:46:37 localhost.localdomain su[14298]: (to postgres) root on none
Feb 20 02:46:39 localhost.localdomain su[14375]: (to postgres) root on none
Feb 20 02:46:39 localhost.localdomain su[14427]: (to postgres) root on none
Feb 20 02:46:40 localhost.localdomain pbs_init.d[14479]: Stopping PBS
Feb 20 02:46:40 localhost.localdomain su[14554]: (to postgres) root on none
Feb 20 02:46:40 localhost.localdomain su[14606]: (to postgres) root on none
Feb 20 02:46:40 localhost.localdomain pbs_init.d[14479]: Waiting for shutdown to complete

I’ve tried disabling the selinux, but it doesn’t work.


#2

Hi,

Could you please share the pbs.conf file and the server logs.

Thanks.


#3

Hi,
It seems you are using localhost.localdomain for server and this hostname being mapped to loopback
address(127.0.0.*) in /etc/hosts. Please setup a network, with hostname of machine mapped to a network IP.

Regards
Dilip


#5

Thanks! That solves my problem. I was testing the server without internet connection, and do not have a DNS server to resolve my hostname. Now I just use plain IP address anywhere. It seems to work!