Qstat -xtw doesn't work, w option needs a,n, T , s or f


#1

Hi,

I am relatively new to the PBS Pro world, I have administered a torque system in the past but it’s been a while. For my current cluster I am running CentOS 7 and because of the updated Kernel I needed to install from source code as the RPM was failing due to missing dependency.

I use an application (Nice-Software EngineFrame) that communicates directly with PBS to create accelerated interactive sessions for users. It also manages authentication, scheduler interfacing and job management and status monitoring.

Currently I am able to create the interactive sessions (simply a front end for qsub commands) I am not able to monitor them due to an “error” with running the command qstat -xtw.

I checked with the developers of Nice-Software and they were able to run the command on their sandbox systems with no issue. when I run it I get the following:

qstat -xtw
qstat: option w can be used only with option a, n, T, s or f
usage:
qstat [-f] [-J] [-p] [-t] [-x] [-E] [-F format] [-D delim] [ job_identifier… | destination… ]
qstat [-a|-i|-r|-H|-T] [-J] [-t] [-u user] [-n] [-s] [-G|-M] [-1] [-w]
[ job_identifier… | destination… ]
qstat -Q [-f] [-F format] [-D delim] [ destination… ]
qstat -q [-G|-M] [ destination… ]
qstat -B [-f] [-F format] [-D delim] [ server_name… ]
qstat --version

I am not sure what is different between our implementations other than they have installed from an RPM and I installed from the source.

Should I uninstall and try an older version of PBS or is this something that is common to all PBS versions.

I really appreciate any help or guidance on this issue.

Regards,

Ahmed.


#2

Could you please try these commands:

  1. qstat -xTw
  2. qstat -wns1
  3. qstat -xt

Could you please share the output of the command used by Nice-Softwaer developers ?
It might have been a wrapper script on top of qstat output.


#3

Hello, this was indeed a change as part of PP-483 and PP-484 to fix a bug. In older versions of PBS Pro qstat -xtw was erroneously accepted (it should have been rejected) and displayed output in what appeared to be alternate format(qsub -a, now required for w), except that the information was incomplete (note the SessID, NDS, and TSK fields).

This should have resulted in the usage error being thrown:

[root@centos7 PBSPro_14.2.2]# qstat -xtw

centos7:
                                                                                                   Req'd  Req'd   Elap
Job ID                         Username        Queue           Jobname         SessID   NDS  TSK   Memory Time  S Time
------------------------------ --------------- --------------- --------------- -------- ---- ----- ------ ----- - -----
0.centos7                      user1           workq           STDIN                --   --    --     --    --  R 00:02:32

This is the correct output from PBS Pro versions before the fix (with the a included in qstat options):

[root@centos7 PBSPro_14.2.2]# qstat -atxw

centos7:
                                                                                                   Req'd  Req'd   Elap
Job ID                         Username        Queue           Jobname         SessID   NDS  TSK   Memory Time  S Time
------------------------------ --------------- --------------- --------------- -------- ---- ----- ------ ----- - -----
0.centos7                      user1           workq           STDIN               7700    1     1    --    --  R 00:02:32

In current PBS Pro you must explicitly include the a, and the fields are of course fully populated as above:

[root@centos7 PBSPro_17.2.0]# qstat -atxw

centos7:
                                                                                                   Req'd  Req'd   Elap
Job ID                         Username        Queue           Jobname         SessID   NDS  TSK   Memory Time  S Time
------------------------------ --------------- --------------- --------------- -------- ---- ----- ------ ----- - -----
0.centos7                      user1           workq           STDIN               5106    1     1    --    --  R 00:00:11

#4

Thank you adarsh and scc for your replies.

I went back to the developer of the tool and it seems that they haven’t updated their PBS calls to address this change.

They informed me that they are planning on rolling out a patch once it is fully tested and supported.

I really appreciate the quick and complete responses.

Sorry for the late reply.

Regards,

Ahmed.