PTL and test groups


#1

I find myself needing to submit a job in a particular group. I see that there are group variables (e.g, TESTGRP1) like the user variables (e.g., TEST_USER1). I just don’t see how I can use them. I know that I use one of the user ones by passing it as the first argument to Job(). I looked at the Job() class and it doesn’t take an equivalent group parameter. I tried to set the group_list attribute with the value of TESTGRP1, and it complained there was no such variable.

The only way I can see to use the groups that are predefined is to use the quoted string name instead of a global define. It would cause test failures if we ever changed the name of the groups.

Any help would be greatly appreciated.

Bhroam


#2

Hey @bhroam This should work fine with little modification in group name as its TSTGRP1 not TESTGRP1.
Can you please try with TSTGRP1? and if you still face an issue please send me PTL logs I will look into issue.


#3

@hirenvadalia
Thanks for the help. It was indeed a typo (TEST vs TST) that caused my issues. I’m curious, is there some reason TST was chosen instead of TEST? I guess I assumed it would follow that if TEST_USER had the ‘E’, so would the group.

Bhroam


#4

If we’re going to be incorporating PTL into our product at some point,
this kind of inconsistency should be fixed.

-Anne


#5

I agree anne. Can you please file an ticket for same? Thanks.


#6

Hi @bhroam I don’t think there particular reason behind choosing TST instead TEST… Right now I can only think one point that to separate out user vs group name.
However as @agurban told we should have consistency in name so that it won’t confuse test writer in future.


#7

I’ve filed PP-743 - “Use consistent naming for PTL components” for
this problem.

Regards,
-Anne