Problem after upgrade to PostreSQL 10.8

#1

We were running PBS 19.0.0 on an Ubuntu 16.04 server and just upgraded to Ubuntu 18.04. This later OS comes with PostreSQL 10.8. When we tried to start PBS, it failed with a message that pbsdatastore couldn’t start because the database was initialized with PostgreSQL 9.5. Does anyone know if postgres 10.8 will work with PBS Pro or have any suggestions to fix this problem?

#2

Hello,

Since the PostgreSQL version on your machine is changed now you should upgrade your PBSPro database as well to PostgreSQL 10.8. PostgreSQL provides a tool pg_upgrade to do this (documentation is here).

Make sure you take a backup of the PBS_HOME directory before you attempt the upgrade.

If you are not worried about losing your configuration and can have a fresh setup, just delete PBS_HOME/datastore directory then run below-mentioned commands to re-initialize your DB with new PostgreSQL.
source /etc/pbs.conf
$PBS_EXEC/libexec/pbs_postinstall
$PBS_EXEC/libexec/pbs_habitat

Hope this helps.

#3

We ran into some complications so we just reverted back to the 9.5 version of postgres for now. We’ll read up on the database conversion process you mentioned and do that upgrade during our next outage. Thanks for your help.