@borlesanket I am fine with nocommonmom options, But I partially agree on reply to my first point.
I don’t like this as default, mean by default I would like go for default PBS behavior (comm and mom on separate machine) which means new option nocommonmom to True as default instead False.
Also if everyone is ok then I would prefer to see new decorator name as “requirements” instead “TestRequirements”
Few cosmetic comments:
Replase FALSE/TRUE with False/True
Replace @TestRequirements with @testrequirements or @test_requirements (if we don’t go for @requirements)
For better readability rename below options of new decorator:
- nomomonserver to no_mom_on_server
- nocommonserver to no_comm_on_server
- nocommonmom to no_comm_on_mom