PBS packaging on Ubuntu


#1

Hi All,

I am working on compiling and packaging PBS on Debian/Ubuntu systems.
PP-384 addresses this requirement.

I request the community to do a thorough review of the pull request.

External interface design and steps can be found at this page.

Thanks,
Prakash


#2

Hi Team,

As per the below link, we are unable to build the PBS package.
https://pbspro.atlassian.net/wiki/spaces/PD/pages/22183970/Steps+to+build+debian+packages

Unable to complete 12 steps
Error Description
fifo.c: In function ‘sched_settings_frm_svr’:
fifo.c:2414:4: error: format not a string literal and no format arguments [-Werror=format-security]
(void)snprintf(path_log, sizeof(path_log), tmp_log_dir);
^
fifo.c:2414:4: error: format not a string literal and no format arguments [-Werror=format-security]
fifo.c:2483:8: warning: ignoring return value of ‘ftruncate’, declared with attribute warn_unused_result [-Wunused-result]
(void)ftruncate(lockfds, (off_t)0);
^
fifo.c:2486:7: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result [-Wunused-result]
(void)write(lockfds, log_buffer, strlen(log_buffer));
^
cc1: some warnings being treated as errors
Makefile:826: recipe for target ‘libpbs_sched_a-fifo.o’ failed
make[3]: *** [libpbs_sched_a-fifo.o] Error 1
make[3]: Leaving directory '/root/build/build/pbspro-18.1.0/src/scheduler’
Makefile:503: recipe for target ‘all-recursive’ failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/root/build/build/pbspro-18.1.0/src’
Makefile:537: recipe for target ‘all-recursive’ failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/root/build/build/pbspro-18.1.0’
dh_auto_build: make -j1 returned exit code 2
debian/rules:18: recipe for target ‘build’ failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Need your support to resolve this error.

Environment details:
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial

Atul Yadav
Locuz HPC Team


#3

That looks like a bug. Could you please provide the output of “gcc --version”?

Thanks.


#4

Hi

Please find the required information
root@master:~# gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/5/lto-wrapper
Target: x86_64-linux-gnu
Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 5.4.0-6ubuntu1~16.04.9’ --with-bugurl=file:///usr/share/doc/gcc-5/README.Bugs --enable-languages=c,ada,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-5 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-5-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-5-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-5-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.9)

Thank You
Atul Yadav


#5

Looks like a much newer version of gcc than I normally use (4.8.5) that must be more sensitive to certain types of errors. Please consider filing a bug at https://pbspro.atlassian.net/ and feel free to contribute a fix! If you don’t file a bug, please let us know and someone will get one filed. Thanks!


#6

Hi,

Can you please raise the ticket also.

Thank You
Atul Yadav


#7

https://pbspro.atlassian.net/browse/PP-1249 has been opened.


#8

Thank You So Much …