Noob question: can't initialize the PBS dataservice

#21

Hi,
Weird…
I tried again but the result is the same.
I didn’t follow your steps exactly, but I’ll post the details:
Postgres: built from source, 9.6.12:

./configure --prefix=/opt/pbs/pgsql
make -j4
make install

PBSpro: git tag v19.1.1:

git checkout v19.1.1
sh autogen.sh
./configure --prefix=/opt/pbs --with-database-dir=/opt/pbs/pgsql --with-database-user=postgres
make -j4
make install
chown -R postgres:postgres /opt/pbs/pgsql
/opt/pbs/libexec/pbs_postinstall
chkconfig --add pbs
service pbs start

(I didn’t create the “pbs” account. is this the problem?)

Mike

#22

Ah okay…
I just see the DB test post you posted earlier.
I’ll try that first.
Sorry!

Mike

#23

Done!
The problem is in the difference of:

make; make install

and

make world; make install-world

when building postgres.
Thank you very much!

1 Like
#24

Hi I get the following when I do my DB test:
ERROR: could not open extension control file “/opt/pbs/pgsql/share/extension/hstore.control”

Regards,
Nkwe

#25

Hi,

Check the permissions for that pgsql dir,
Its should be owned by database user.

Ideally, i will prefer build in user’s home directory and configure with PBS pro, so that user can easily access without any permissions error.

Additionally, plz check whether that hstore files are available in /pgsqlshare/extension dir. If not available, plz do rebuild you pgsql with ./configure, make world, make install-world.

Warm regards,
Brem Anand J K

#26

Hi Brem,

Thank you.

It is working.

Regards,
Nkwe

1 Like
#27

I’m attempting to compile 19.1.1 from source. I have installed the newer postgresql 9.6 packages using the postgres repo. During the make phase, I’m consistently getting this error:


/lib64/python2.7/config -lpython2.7 -lpthread -lutil -lm -lssl -lcrypto -ldl -lcrypt -lc
/bin/ld: /usr/pgsql-9.6/lib/libpq.a(fe-connect.o): undefined reference to symbol ‘gss_delete_sec_context@@gssapi_krb5_2_MIT
//usr/lib64/libgssapi_krb5.so.2: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status

I have build the newest krb5 from source and loaded it with an environment module, but I can’t seem to get configure to point to the newer version. Any ideas?

Thanks,
Brian

#28

As root, I can get the new krb5 module to load, but still getting errors in configure step:

/bin/ld: /usr/pgsql-11/lib/libpq.a(fe-connect.o): undefined reference to symbol ‘gss_delete_sec_context@@gssapi_krb5_2_MIT
/apps/krb5/1.17/lib/libgssapi_krb5.so.2: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status