Noob question: can't initialize the PBS dataservice


#1

Hi,
I’m trying the PBSpro for the first time, aiming to replace the no-longer-opensource Torque.
I followed the INSTALL file instructions and can build the code on a CentOS 6.10 test machine from scratch.
However, when I tried to start the service, it gives the following error:
[root@c6 libexec]# service pbs restart
Restarting PBS
Stopping PBS
PBS sched - was pid: 5019
PBS comm - was pid: 5004
Waiting for shutdown to complete
/sbin/chkconfig
Starting PBS
/cluster/pbspro/sbin/pbs_comm ready (pid=6007), Proxy Name:c6:17001, Threads:4
PBS comm
Creating usage database for fairshare.
PBS sched
Connecting to PBS dataservice…connected to PBS dataservice@c6
Server@c6: Server@c6, Failed to initialize PBS dataservice:[Prepare of statement insert_job failed: ERROR: relation “pbs.job” does not exist
LINE 1: insert into pbs.job (ji_jobid,ji_state,ji_substate,ji_svrfla…
^]
pbs_server startup failed, exit 255 aborting.
Did I miss something in the process?

Mike Chen
Research Assistant
Dept. of Atmospheric Science
National Taiwan University


#2

The problem does not present in v14.1.2…
Not sure about the cause, maybe PostgreSQL version compatilibity?
Since the target system is CentOS 6, I’ll test with v14.1.2 first.
Input welcomed :slight_smile:


#3

Hi,
I have not seen this problem myself but since the error is related to db schema you have rightly pointed that PostgreSQL incompatibility might be causing this.
There were some changes made specific to database in version 19 and it would require you to install postgresql-contrib package on your system. Can you please install that package and try rebuilding/installing PBS again?


#4

Hi,
Thanks for the reply!
I tried with v18.1.3 and it works.
So as you expected, the problem’s on v19 only.
I tried with v19.1.1 again, but found that I already had that postgresql-contrib package installed when the problem occurred.
Both the postgresql and postgresql-contrib are in version 8.4.20-8.el6.9.

Mike


#5

Hi @mikescchen

Yes, I have the same problem.

I saw the same error with latest commit in master branch (a few week ago)
(my test VM environment is: config.vm.box = “centos/7”)

Instead, I use the following commit in our cluster and test VM.

  • commit 9ad06407424b16c0f097f56df11fd309f39d52d5
    | Author: Bhroam Mann bmann@altair.com
    | Date: Thu Feb 1 10:23:23 2018 -0800

This version don’t give me the errors.


#6

Hi~
I did a quick test with tag v19.1.1 and the latest master branch.
Neither of them have the said problem on CentOS 7.6.
FYI~

Mike


#7

Hi

Which version of postgres is working with v19.0.0

Regards,
Nkwe


#8

Can you please try installing a newer postgres(including contrib package) version (like 9.6) on Centos6.10 and check again?

Thanks!
Arun