Licenses valid for 0 Floating hosts


#1

Hi there,
I have applied one PBS Pro trial license and tried to install PBS Pro 14.2.6. The detailed steps are as follows:

  1. Create one account in https://secure.altair.com/UserArea/license_man.php and applied 30 days free trial license for 0.03 HWU with hostid 00001701A3E0,hostid type “Ethernet”. Save license file as “altair-serv.cfg”
  2. Download the Altair License Server and add the “altair-serv.cfg” license file.
  3. Check the license server is running.

[opc@pbsproserver usr]$ sudo systemctl status altairlmxd.service
● altairlmxd.service - LSB: Altair_Lmxd for Altair products
Loaded: loaded (/etc/rc.d/init.d/altairlmxd; bad; vendor preset: disabled)
Active: active (running) since Tue 2018-11-06 02:12:04 GMT; 2h 5min ago
Docs: man:systemd-sysv-generator(8)
Tasks: 21
Memory: 724.0K
CGroup: /system.slice/altairlmxd.service
└─1988 /usr/local/altair/licensing13.0/bin/lmx-serv -b -c /usr/local/altair/licensing13.0/altair-serv.cfg
Nov 06 02:12:04 pbsproserver systemd[1]: Starting LSB: Altair_Lmxd for Altair products…
Nov 06 02:12:04 pbsproserver altairlmxd[1924]: Starting Altair License Manager…
Nov 06 02:12:04 pbsproserver altairlmxd[1924]: The Altair License Manager was successfully started.
Nov 06 02:12:04 pbsproserver systemd[1]: Started LSB: Altair_Lmxd for Altair products.

  1. Created user pbsdata and install pbs standalone server.
  2. Start pbs service.

[opc@pbsproserver licensing13.0]$ sudo systemctl status pbs
● pbs.service - Portable Batch System
Loaded: loaded (/opt/pbs/libexec/pbs_init.d; enabled; vendor preset: disabled)
Active: active (running) since Tue 2018-11-06 03:17:37 GMT; 55min ago
Docs: man:pbs(8)
Process: 12128 ExecStop=/opt/pbs/libexec/pbs_init.d stop stop (code=exited, status=0/SUCCESS)
Process: 12788 ExecStart=/opt/pbs/libexec/pbs_init.d start start (code=exited, status=0/SUCCESS)
Tasks: 12
Memory: 11.8M
CGroup: /system.slice/pbs.service
├─12831 /opt/pbs/sbin/pbs_comm
├─12859 /opt/pbs/sbin/pbs_mom
├─12871 /opt/pbs/sbin/pbs_sched
├─13067 /opt/pbs/sbin/pbs_ds_monitor monitor
├─13097 /opt/pbs/pgsql/bin/postgres -D /var/spool/pbs/datastore -p 15007
├─13106 postgres: logger process
├─13109 postgres: checkpointer process
├─13110 postgres: writer process
├─13111 postgres: wal writer process
├─13112 postgres: autovacuum launcher process
├─13113 postgres: stats collector process
├─13129 postgres: pbsdata pbs_datastore 10.0.0.253(48344) idle
└─13143 /opt/pbs/sbin/pbs_server.bin
Nov 06 03:17:32 pbsproserver pbs_init.d[12788]: PBS sched
Nov 06 03:17:33 pbsproserver su[12893]: (to pbsdata) root on none
Nov 06 03:17:33 pbsproserver su[12926]: (to pbsdata) root on none
Nov 06 03:17:33 pbsproserver su[12988]: (to pbsdata) root on none
Nov 06 03:17:33 pbsproserver su[13022]: (to pbsdata) root on none
Nov 06 03:17:33 pbsproserver su[13068]: (to pbsdata) root on none
Nov 06 03:17:37 pbsproserver pbs_init.d[12788]: Connecting to PBS dataservice…connected to PBS dataservice@pbsproserver
Nov 06 03:17:37 pbsproserver pbs_init.d[12788]: Licenses valid for 0 Floating hosts
Nov 06 03:17:37 pbsproserver pbs_init.d[12788]: PBS server
Nov 06 03:17:37 pbsproserver systemd[1]: Started Portable Batch System.

  1. Checked the server log:

11/06/2018 03:17:37;0004;Server@pbsproserver;Svr;Server@pbsproserver;Hostid is 0x000afd00
11/06/2018 03:17:37;0004;Server@pbsproserver;Svr;Server@pbsproserver;Licenses valid for 0 Floating hosts

  1. When submit job and trace it,

[opc@pbsproserver server_logs]$ tracejob 0
Job: 0.pbsproserver
11/06/2018 03:04:59 L Considering job to run
11/06/2018 03:04:59 L Could not run job - unable to obtain 1 cpu licenses. avail_licenses=0
11/06/2018 03:04:59 S enqueuing into workq, state 1 hop 1

Not sure why the license invalid. And my hostid is like this:

[root@pbsproserver bin]# ./almutil -hostid
AltairLM End-user Utility v13.0.0 build 156135 (Jun 3 2016)
Copyright © 2016 Altair Engineering, Inc. All rights reserved.
ETHERNET: ens3
Hostid: 00001701A3E0
ETHERNET: virbr0
Hostid: 525400F20968
ETHERNET: virbr0-nic
Hostid: 525400F20968

Could you please help me find why the license invalid? Thanks a lot!


#2
  1. Could you please share the output of the below commands:
  • qmgr -c “p s”
  • qstat -Bf
  1. Did you create a floating license file or a socket license file ?

  2. If you have created a socket license file, then you have to save the license file on the PBS Server host
    and run the below command
    qmgr -c “set server pbs_license_info=/path/to/saved/license/file/altair_lic.dat”

  3. If you have created a floating license file , then you have to point the PBS Server to checkout the licenses from the license server.
    qmgr -c “set server pbs_license_info=6200@hostname-of-the-license-server”

Please note that you are using a commercial product, hence please contact the support team of your region.
This forum is for PBS Professional Open Source community.

Thank you


#3

Thanks a lot for the reply.

  1. output for qmgr and qstat

[root@pbsproserver ~]# qmgr -c “p s”
Unknown Host.
qmgr: cannot connect to server s”
[root@pbsproserver ~]# qstat -Bf
Server: pbsproserver
server_state = Active
server_host = pbsproserver.sub003090.vcnplugin.com
scheduling = True
total_jobs = 1
state_count = Transit:0 Queued:1 Held:0 Waiting:0 Running:0 Exiting:0 Begun
:0
acl_roots = root
default_queue = workq
log_events = 511
mail_from = adm
query_other_jobs = True
resources_default.ncpus = 1
default_chunk.ncpus = 1
scheduler_iteration = 600
FLicenses = 0
resv_enable = True
node_fail_requeue = 310
max_array_size = 10000
pbs_license_info = /usr/local/altair/licensing13.0/altair_lic.dat
pbs_license_min = 1
pbs_license_max = 2147483647
pbs_license_linger_time = 31536000
license_count = Avail_Global:0 Avail_Local:0 Used:0 High_Use:0 Avail_Socket
s:0 Unused_Sockets:0
pbs_version = 14.2.6.20180327140341
eligible_time_enable = False
max_concurrent_provision = 5

  1. I am creating one floating license file.
  2. I have run the below command:

qmgr -c "set server pbs_license_info=/usr/local/altair/licensing13.0/altair_lic.dat"

I have tried to contact the support in my region but no one answered the phone. Will try it tomorrow.


#4

Please let us know whether your license file has this format

FEATURE xxxxxxxxxxxxx
{
VENDOR = ALTAIR
COUNT = xxxxxx
KEYTYPE = EXCLUSIVE
VERSION = xxx
START = 2018-11-xx
END = 2018-11-xx
BORROW = 336
SHARE = CUSTOM|VIRTUAL
COMMENT = " Server Info: ETHERNET = xxxxxxxxxx"
SN = “xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx”
KEY =

############### or this format #################################
FEATURE xxxxxx
{
VENDOR = ALTAIR
VERSION = 12.0
START = 2018-09-xx
END = 2018-10-xx
SHARE = xxxx
COMMENT = " Server Info: ETHERNET:xxxx, Failover Server Info: "
OPTIONS = “SOCKETS=xxx:CORES=xxx”


#5

Thansk a lot for the quick response. My license file is like

FEATURE xxxxxxxxxxxxx
{
VENDOR = ALTAIR
COUNT = xxxxxx
KEYTYPE = EXCLUSIVE
VERSION = xxx
START = 2018-11-xx
END = 2018-11-xx
BORROW = 336
SHARE = CUSTOM|VIRTUAL
COMMENT = " Server Info: ETHERNET = xxxxxxxxxx"
SN = “xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx”
KEY =

And it seemed I need to try “qmgr -c “set server pbs_license_info=6200@hostname-of-the-license-server”” this.


#6

Sorry, saw this late . if you have a floating license file.

  • then you need to download Altair License Manager v14.0
  • deploy this license file (altair_lic.dat) to /usr/local/altair/licensing13.0
  • start the license services /etc/init.d/altairlmxd start
  • qmgr -c “set server pbs_license_info=6200@hostname-of-altair-license-manager-system”

Note: Altair License Manager should be deployed on the system which has the MAC ID mentioned in the license file. Altair License Manager can be hosted on the PBS Server system or a different system.


#7

Thanks a lot. It is working now.
I have followed your steps and now it is working. Thanks so much!


#8

Nice one ! Thank you


#9

Thanks so much for your help!